読者です 読者をやめる 読者になる 読者になる

yuriko’s blog

SIerに勤めるSE、元Javaプログラマ。一からswiftなどのアプリ開発用言語を身につけるべくもがきまくります。

swift swift3でswift2でのコーディングをする

お久しぶりです。。
更新が途絶えてしまいました・・・よくないです。

さて、こちらですが。Xcode8使うとSwift3になってしまいますよね。
一方、サンプルコードなどはまだまだSwift2系が多く、エラー出まくりで心が折れてしまいます。。
そんなあなたに!実は設定でいけるようです。
ただし、アプリごとのようですが。

作成しているアプリのトップを選択すると、こういう感じの画面になるかと思います。
f:id:yurikoueda:20161211210137p:plain
これの、「Use Legacy Swift Language Version」 を「Yes」に変更します。

これでオッケー!!

煩わしいエラーがへる!!!嬉しい!